WeTheArmed.com

General Topics => R & R => Science and Technology => Topic started by: Nightcrawler on January 24, 2015, 11:34:39 pm

Title: Wifi Not Working
Post by: Nightcrawler on January 24, 2015, 11:34:39 pm
Well, on the old beater lappy, I saved the pictures and successfully installed a simple, clean version of Linux called "Elementary OS".  Very nice.

...Except the wifi doesn't work.  The computer has a manual switch, and even if it's on, it's unaware of the wifi radio, apparently.   

But really, what did I expect?  It's Linux.  Of course it doesn't work.  If you want things to just work, like some kind of illiterate barbarian, you should get a Windows system, or a Mac.

*SIGH*  :banghead

Any thoughts?
Title: Re: Wifi Not Working
Post by: Nightcrawler on January 25, 2015, 12:10:30 am
I may have gotten it figured out.  Let me see...

Well, the wifi light is on, the driver has been activated, but I still can't turn it on.

fluff you, Linux.  :facepalm
Title: Re: Wifi Not Working
Post by: Nightcrawler on January 25, 2015, 01:29:02 am
So, to recap, I took an old XP laptop and installed Elementary OS on it, because I thought maybe it'd run a little better on an older system, and because of a bizarre password malfunction I couldn't actually get into Windows.

Well, I have the Linux-based OS installed, and now I can only get onto the internet if I plug an ethernet cable into it, like it was nineteen-fluffing-ninety-seven or something.  I followed all of the instructions I could find for activating the wifi driver, and it still doesn't work.

Everything else I can find, support wise, boils down to typing in dozens of different commands into the terminal and seeing if they work.  The main thing my friends use this laptop for is internet crap, and now they can't do that.  I installed Linux and ruined the functionality of this machine.

I am...frustrated.

I hate Linux.

You know how likes Linux?

(http://31.media.tumblr.com/197c6ec7f64a514f2773407cb849a7c1/tumblr_n2ua224aEq1syqltto1_500.jpg)

Also, probably Hitler.  :banghead
Title: Re: Wifi Not Working
Post by: seanp on January 25, 2015, 02:54:51 am
Hmm... sounds like you need a hammer...
Title: Re: Wifi Not Working
Post by: Nightcrawler on January 25, 2015, 02:56:35 am
Thanks to a friend-of-a-friend who actually knows something about Linux (and who I grudgingly admit lacks a neck-beard and doesn't wear a Fedora).

It's good.  The hammer option was next.  It was some obscure command I had to enter into the terminal.   :facepalm
Title: Re: Wifi Not Working
Post by: seanp on January 25, 2015, 02:58:19 am
Actually, I kind of fluffed up a laptop of mine a few years back in a similar way.  I wound up buying a $20 Cisco USB WIFI stick and plugged it in.  Problem solved.